BGP Lab (2)

Az előző cikkben R1-R4 között építettük fel a konfigurációt. Folytassuk most a többi routerrel.

Topológia:

BGP-2
Annyi különbség van AS200 és AS300 iBGP kapcsolataiban, hogy AS 300-ban full mesh-t építünk. Vegyük észre, hogy mivel a BGP TCP/179 porton kommunikál, nem kell fizikailag is minden routert összekötnünk (azaz R6 és R7 nincs összekötve, mégis ki tudjuk építeni a BGP kapcsolatot). Megfűszerezzük még a full mesh-t azzal, hogy R5-n peer-group-ként konfiguráljuk a neighbor routereket, nem külön-külön. Ezzel konfigurációt egyszerűsítünk.

R4 konfigja annyiban változik, hogy R5 felé előkészítjük az interface-t és a BGP-t. Semmi extra.

***
R4
***

!
interface FastEthernet0/1
 ip address 10.0.3.1 255.255.255.0
 duplex auto
 speed auto
!
router bgp 200
 neighbor 10.0.3.2 remote-as 300
 no auto-summary
!

R5-n mutatom be a peer-group-os megoldást. A peer-group alatt adjuk meg az update-source-t és az AS-t (tehát ami mindegyik neighbor-ben közös). Utána már csak aktiváljuk a neighboroket peer-group alapján.

***
R5
***

!
 !
 interface Loopback1
 ip address 5.5.5.5 255.255.255.255
 ip ospf 1 area 0
 !
 interface FastEthernet0/0
 ip address 10.0.3.2 255.255.255.0
 duplex auto
 speed auto
 !
 interface FastEthernet0/1
 ip address 10.0.4.1 255.255.255.0
 ip ospf network point-to-point
 ip ospf 1 area 0
 duplex auto
 speed auto
 !
 interface FastEthernet1/0
 ip address 10.0.5.1 255.255.255.0
 ip ospf network point-to-point
 ip ospf 1 area 0
 duplex auto
 speed auto
 !
 router ospf 1
 router-id 5.5.5.5
 log-adjacency-changes
 !
 router bgp 300
 no synchronization
 bgp router-id 5.5.5.5
 bgp log-neighbor-changes
 network 5.5.5.5 mask 255.255.255.255
 neighbor BGP peer-group
 neighbor BGP remote-as 300
 neighbor BGP update-source Loopback1
 neighbor 6.6.6.6 peer-group BGP
 neighbor 7.7.7.7 peer-group BGP
 neighbor 10.0.3.1 remote-as 200
 no auto-summary
 !

***
R6
***

!
 !
 interface Loopback1
 ip address 6.6.6.6 255.255.255.255
 ip ospf 1 area 0
 !
 interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
 !
 interface FastEthernet0/1
 ip address 10.0.4.2 255.255.255.0
 ip ospf network point-to-point
 ip ospf 1 area 0
 duplex auto
 speed auto
 !
 router ospf 1
 router-id 6.6.6.6
 log-adjacency-changes
 !
 router bgp 300
 no synchronization
 bgp router-id 6.6.6.6
 bgp log-neighbor-changes
 network 6.6.6.6 mask 255.255.255.255
 neighbor 5.5.5.5 remote-as 300
 neighbor 5.5.5.5 update-source Loopback1
 neighbor 7.7.7.7 remote-as 300
 neighbor 7.7.7.7 update-source Loopback1
 no auto-summary
 !

***
R7
***

!
 interface Loopback1
 ip address 7.7.7.7 255.255.255.255
 ip ospf 1 area 0
 !
 interface FastEthernet0/0
 ip address 10.0.5.2 255.255.255.0
 ip ospf network point-to-point
 ip ospf 1 area 0
 duplex auto
 speed auto
 !
 interface FastEthernet0/1
 ip address 10.0.6.1 255.255.255.0
 duplex auto
 speed auto
 !
 router ospf 1
 router-id 7.7.7.7
 log-adjacency-changes
 !
 router bgp 300
 no synchronization
 bgp router-id 7.7.7.7
 bgp log-neighbor-changes
 network 7.7.7.7 mask 255.255.255.255
 neighbor 5.5.5.5 remote-as 300
 neighbor 5.5.5.5 update-source Loopback1
 neighbor 6.6.6.6 remote-as 300
 neighbor 6.6.6.6 update-source Loopback1
 neighbor 10.0.6.2 remote-as 400
 no auto-summary
 !

***
R8
***

!
 !
 interface Loopback1
 ip address 8.8.8.8 255.255.255.255
 !
 interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
 !
 interface FastEthernet0/1
 ip address 10.0.6.2 255.255.255.0
 duplex auto
 speed auto
 !
 router bgp 400
 no synchronization
 bgp router-id 8.8.8.8
 bgp log-neighbor-changes
 network 8.8.8.8 mask 255.255.255.255
 neighbor 10.0.6.1 remote-as 300
 no auto-summary
 !

Akkor nézzük először is, miért van szükség iBGP esetén full mesh-re? Gondoljunk bele, eBGP esetén miért nem tud loop kialakulni: az AS_PATH attribútum miatt. Ha egy router látja a saját AS-ét az NLRI AS_PATH listában, akkor nem használhatja azt. Logikus.
iBGP update-k esetén az AS_PATH attribútum nem frissül. Ezért van is egy olyan szabály, hogy iBGP által használt route-t iBGP neighbor-nek nem hirdetünk tovább. A megoldás lehet a full-mesh, route-reflector, confederation kialakítása.

Célunk, hogy R8 tudja pingelni R1 Loopback1 interface-t. Nézzük, megy -e ez.

R8#ping 1.1.1.1 source lo1
Type escape sequence to abort.
 Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
 Packet sent with a source address of 8.8.8.8
 .....
 Success rate is 0 percent (0/5)
 R8#

Nem. Mit tudunk 1.1.1.1/32-ről?

R8#sh ip route 1.1.1.1
 % Network not in table
 R8#sh ip bgp 1.1.1.1
 % Network not in table
 R8#

Hm…

R8#sh ip bgp
 BGP table version is 7, local router ID is 8.8.8.8
 Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
 r RIB-failure, S Stale
 Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
 *> 5.5.5.5/32 10.0.6.1 0 300 i
 *> 6.6.6.6/32 10.0.6.1 0 300 i
 *> 7.7.7.7/32 10.0.6.1 0 0 300 i
 *> 8.8.8.8/32 0.0.0.0 0 32768 i
 R8#

R1-R4 Loopback címeit nem látjuk. Keressük meg a hibát.

R5 tudja róluk?

R5#sh ip bgp
 BGP table version is 16, local router ID is 5.5.5.5
 Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
 r RIB-failure, S Stale
 Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
 *> 1.1.1.1/32 10.0.3.1 0 200 100 i
 *> 2.2.2.2/32 10.0.3.1 0 200 i
 *> 3.3.3.3/32 10.0.3.1 0 200 i
 *> 4.4.4.4/32 10.0.3.1 0 0 200 i
 *> 5.5.5.5/32 0.0.0.0 0 32768 i
 r>i6.6.6.6/32 6.6.6.6 0 100 0 i
 r>i7.7.7.7/32 7.7.7.7 0 100 0 i
 * i8.8.8.8/32 10.0.6.2 0 100 0 400 i
 R5#

Igen. Részletesebben:

R5#sh ip bgp 1.1.1.1
 BGP routing table entry for 1.1.1.1/32, version 7
 Paths: (1 available, best #1, table Default-IP-Routing-Table)
 Advertised to update-groups:
 2
 200 100
 10.0.3.1 from 10.0.3.1 (4.4.4.4)
 Origin IGP, localpref 100, valid, external, best
 R5#

De a next-hop 10.0.3.1, ebből lesz gond.

És R7?

R7#sh ip bgp 1.1.1.1
 BGP routing table entry for 1.1.1.1/32, version 0
 Paths: (1 available, no best path)
 Not advertised to any peer
 200 100
 10.0.3.1 (inaccessible) from 5.5.5.5 (5.5.5.5)
 Origin IGP, metric 0, localpref 100, valid, internal
 R7#

Ugyanaz a hiba, mint az előző posztban, AS200 esetében. Ha a next-hop nem elérhető, a BGP NEM hirdeti tovább a route-t.

R7#sh ip bgp neigh 10.0.6.2 advertised-routes
 BGP table version is 10, local router ID is 7.7.7.7
 Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
 r RIB-failure, S Stale
 Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
 r>i5.5.5.5/32 5.5.5.5 0 100 0 i
 r>i6.6.6.6/32 6.6.6.6 0 100 0 i
 *> 7.7.7.7/32 0.0.0.0 0 32768 i
Total number of prefixes 3
 R7#

Most a next-hop-self helyett behirdetem a transit linket OSPF-be, a változatosság kedvéért (és passive interface-t konfigurálok f0/0-ra).

R5(config)#int f0/0
 R5(config-if)#ip ospf 1 a 0
 R5(config-if)#router ospf 1
 R5(config-router)#passive-interface f0/0
 R5(config-router)#end

Ezután R7-en:

R7#sh ip bgp 1.1.1.1
 BGP routing table entry for 1.1.1.1/32, version 11
 Paths: (1 available, best #1, table Default-IP-Routing-Table)
 Flag: 0x820
 Advertised to update-groups:
 1
 200 100
 10.0.3.1 (metric 20) from 5.5.5.5 (5.5.5.5)
 Origin IGP, metric 0, localpref 100, valid, internal, best
 R7#

Már hirdetjük is a route-kat:

R7#sh ip bgp neigh 10.0.6.2 advertised-routes
 BGP table version is 14, local router ID is 7.7.7.7
 Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
 r RIB-failure, S Stale
 Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
 *>i1.1.1.1/32 10.0.3.1 0 100 0 200 100 i
 *>i2.2.2.2/32 10.0.3.1 0 100 0 200 i
 *>i3.3.3.3/32 10.0.3.1 0 100 0 200 i
 *>i4.4.4.4/32 10.0.3.1 0 100 0 200 i
 r>i5.5.5.5/32 5.5.5.5 0 100 0 i
 r>i6.6.6.6/32 6.6.6.6 0 100 0 i
 *> 7.7.7.7/32 0.0.0.0 0 32768 i
Total number of prefixes 7
 R7#

Érdekességként: update-group-pal is tudunk információt nyerni, kinek hirdetjük a route-t. Nézzük meg az alábbi kimenetet:

R7#sh ip bgp 1.1.1.1
 BGP routing table entry for 1.1.1.1/32, version 11
 Paths: (1 available, best #1, table Default-IP-Routing-Table)
 Flag: 0x820
 Advertised to update-groups:
 1
 200 100
 10.0.3.1 (metric 20) from 5.5.5.5 (5.5.5.5)
 Origin IGP, metric 0, localpref 100, valid, internal, best
 R7#

Nézzük, ki tagja a group 1-nek:

R7#sh ip bgp update-group 1
 BGP version 4 update-group 1, external, Address Family: IPv4 Unicast
 BGP Update version : 14/0, messages 0
 Update messages formatted 7, replicated 0
 Number of NLRIs in the update sent: max 3, min 0
 Minimum time between advertisement runs is 30 seconds
 Has 1 member (* indicates the members currently being sent updates):
 10.0.6.2
R7#

Szóval 10.0.6.2 megkapja a route-t.

Teszteljük hát ismét a pinget R8-ról.

R8#sh ip bgp
 BGP table version is 11, local router ID is 8.8.8.8
 Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
 r RIB-failure, S Stale
 Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
 *> 1.1.1.1/32 10.0.6.1 0 300 200 100 i
 *> 2.2.2.2/32 10.0.6.1 0 300 200 i
 *> 3.3.3.3/32 10.0.6.1 0 300 200 i
 *> 4.4.4.4/32 10.0.6.1 0 300 200 i
 *> 5.5.5.5/32 10.0.6.1 0 300 i
 *> 6.6.6.6/32 10.0.6.1 0 300 i
 *> 7.7.7.7/32 10.0.6.1 0 0 300 i
 *> 8.8.8.8/32 0.0.0.0 0 32768 i
 R8#
 R8#ping 1.1.1.1 source lo1
Type escape sequence to abort.
 Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
 Packet sent with a source address of 8.8.8.8
 .....
 Success rate is 0 percent (0/5)
 R8#

Még mindig nem jó. Nézzük, meddig jutunk el:

R8#trace 1.1.1.1 sou lo1
Type escape sequence to abort.
 Tracing the route to 1.1.1.1
1 10.0.6.1 40 msec 52 msec 40 msec
 2 *

Már sejthetitek, hogy megint a next-hop lesz a ludas. R7 next-hop-ként a 10.0.6.2-t fogja hirdetni AS300-ban, ez lesz a gond.

R5#sh ip bgp 8.8.8.8
 BGP routing table entry for 8.8.8.8/32, version 0
 Paths: (1 available, no best path)
 Not advertised to any peer
 400
 10.0.6.2 (inaccessible) from 7.7.7.7 (7.7.7.7)
 Origin IGP, metric 0, localpref 100, valid, internal
 R5#

Next-hop-self…

R7(config)#router bgp 300
 R7(config-router)#neigh 5.5.5.5 next-hop-self
 R7(config-router)#neigh 6.6.6.6 next-hop-self
 R7(config-router)#end

Most már oké…

R5#sh ip bgp 8.8.8.8
 BGP routing table entry for 8.8.8.8/32, version 17
 Paths: (1 available, best #1, table Default-IP-Routing-Table)
 Flag: 0x820
 Advertised to update-groups:
 1
 400
 7.7.7.7 (metric 2) from 7.7.7.7 (7.7.7.7)
 Origin IGP, metric 0, localpref 100, valid, internal, best
 R5#

De még mindig van hiba.

R8#trace 1.1.1.1 sou lo1
Type escape sequence to abort.
 Tracing the route to 1.1.1.1
1 10.0.6.1 40 msec 60 msec 44 msec
 2 10.0.5.1 40 msec 60 msec 28 msec
 3 10.0.3.1 64 msec 48 msec 40 msec
 4
 R8#

Kitalálható, hogy a hiba AS200-ban lesz. Ott is next-hop gond.

R4#sh ip bgp 8.8.8.8
 BGP routing table entry for 8.8.8.8/32, version 15
 Paths: (1 available, best #1, table Default-IP-Routing-Table)
 Flag: 0x820
 Advertised to update-groups:
 2
 300 400
 10.0.3.2 from 10.0.3.2 (5.5.5.5)
 Origin IGP, localpref 100, valid, external, best
 R4#

R2-n:

 R2#sh ip bgp 8.8.8.8
 BGP routing table entry for 8.8.8.8/32, version 0
 Paths: (1 available, no best path)
 Not advertised to any peer
 300 400, (Received from a RR-client)
 10.0.3.2 (inaccessible) from 4.4.4.4 (4.4.4.4)
 Origin IGP, metric 0, localpref 100, valid, internal
 R2#

Megoldás:

R4(config)#router bgp 200
R4(config-router)#neigh 2.2.2.2 next-hop-self
R4(config-router)#end

Teszt

R8#ping 1.1.1.1 source lo1
Type escape sequence to abort.
 Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
 Packet sent with a source address of 8.8.8.8
 !!!!!
 Success rate is 100 percent (5/5), round-trip min/avg/max = 44/72/112 ms
 R8#
R8#trace 1.1.1.1 sou lo1
Type escape sequence to abort.
 Tracing the route to 1.1.1.1
1 10.0.6.1 56 msec 44 msec 16 msec
 2 10.0.5.1 20 msec 36 msec 16 msec
 3 10.0.3.1 88 msec 52 msec 60 msec
 4 10.0.2.1 48 msec 48 msec 60 msec
 5 10.0.0.1 88 msec 100 msec 96 msec
 R8#

Működik!

Nyilván ezeket a hibákat már akkor láttam, mikor konfiguráltam. Ezeket a dolgokat fejben kell tartani BGP konfigurációnál. Egy idő után már “lelki szemeivel” látja az ember :-).

Nézzük TCL-lel, mindegyik router eléri -e a másik Lo1 interface-t (végső teszt).

tclsh
 foreach X {
 1.1.1.1
 2.2.2.2
 3.3.3.3
 4.4.4.4
 5.5.5.5
 6.6.6.6
 7.7.7.7
 8.8.8.8
 } { ping $X source lo1 }

R1

Type escape sequence to abort.
 Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
 Packet sent with a source address of 1.1.1.1
 !!!!!
 Success rate is 100 percent (5/5), round-trip min/avg/max = 4/4/4 ms
 Type escape sequence to abort.
 Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
 Packet sent with a source address of 1.1.1.1
 !!!!!
 Success rate is 100 percent (5/5), round-trip min/avg/max = 8/24/56 ms
 Type escape sequence to abort.
 Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
 Packet sent with a source address of 1.1.1.1
 !!!!!
 Success rate is 100 percent (5/5), round-trip min/avg/max = 20/53/116 ms
 Type escape sequence to abort.
 Sending 5, 100-byte ICMP Echos to 4.4.4.4, timeout is 2 seconds:
 Packet sent with a source address of 1.1.1.1
 !!!!!
 Success rate is 100 percent (5/5), round-trip min/avg/max = 16/38/64 ms
 Type escape sequence to abort.
 Sending 5, 100-byte ICMP Echos to 5.5.5.5, timeout is 2 seconds:
 Packet sent with a source address of 1.1.1.1
 !!!!!
 Success rate is 100 percent (5/5), round-trip min/avg/max = 36/53/68 ms
 Type escape sequence to abort.
 Sending 5, 100-byte ICMP Echos to 6.6.6.6, timeout is 2 seconds:
 Packet sent with a source address of 1.1.1.1
 !!!!!
 Success rate is 100 percent (5/5), round-trip min/avg/max = 44/61/80 ms
 Type escape sequence to abort.
 Sending 5, 100-byte ICMP Echos to 7.7.7.7, timeout is 2 seconds:
 Packet sent with a source address of 1.1.1.1
 !!!!!
 Success rate is 100 percent (5/5), round-trip min/avg/max = 40/60/84 ms
 Type escape sequence to abort.
 Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:
 Packet sent with a source address of 1.1.1.1
 !!!!!
 Success rate is 100 percent (5/5), round-trip min/avg/max = 64/82/100 ms
 R1(tcl)#

R2

Type escape sequence to abort.
 Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
 Packet sent with a source address of 2.2.2.2
 !!!!!
 Success rate is 100 percent (5/5), round-trip min/avg/max = 12/35/64 ms
 Type escape sequence to abort.
 Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
 Packet sent with a source address of 2.2.2.2
 !!!!!
 Success rate is 100 percent (5/5), round-trip min/avg/max = 1/3/4 ms
 Type escape sequence to abort.
 Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
 Packet sent with a source address of 2.2.2.2
 !!!!!
 Success rate is 100 percent (5/5), round-trip min/avg/max = 8/31/64 ms
 Type escape sequence to abort.
 Sending 5, 100-byte ICMP Echos to 4.4.4.4, timeout is 2 seconds:
 Packet sent with a source address of 2.2.2.2
 !!!!!
 Success rate is 100 percent (5/5), round-trip min/avg/max = 8/32/56 ms
 Type escape sequence to abort.
 Sending 5, 100-byte ICMP Echos to 5.5.5.5, timeout is 2 seconds:
 Packet sent with a source address of 2.2.2.2
 !!!!!
 Success rate is 100 percent (5/5), round-trip min/avg/max = 16/36/76 ms
 Type escape sequence to abort.
 Sending 5, 100-byte ICMP Echos to 6.6.6.6, timeout is 2 seconds:
 Packet sent with a source address of 2.2.2.2
 !!!!!
 Success rate is 100 percent (5/5), round-trip min/avg/max = 24/47/76 ms
 Type escape sequence to abort.
 Sending 5, 100-byte ICMP Echos to 7.7.7.7, timeout is 2 seconds:
 Packet sent with a source address of 2.2.2.2
 !!!!!
 Success rate is 100 percent (5/5), round-trip min/avg/max = 20/43/76 ms
 Type escape sequence to abort.
 Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:
 Packet sent with a source address of 2.2.2.2
 !!!!!
 Success rate is 100 percent (5/5), round-trip min/avg/max = 36/56/88 ms
 R2(tcl)#

R3

Type escape sequence to abort.
 Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
 Packet sent with a source address of 3.3.3.3
 !!!!!
 Success rate is 100 percent (5/5), round-trip min/avg/max = 20/42/60 ms
 Type escape sequence to abort.
 Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
 Packet sent with a source address of 3.3.3.3
 !!!!!
 Success rate is 100 percent (5/5), round-trip min/avg/max = 8/24/48 ms
 Type escape sequence to abort.
 Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
 Packet sent with a source address of 3.3.3.3
 !!!!!
 Success rate is 100 percent (5/5), round-trip min/avg/max = 1/3/4 ms
 Type escape sequence to abort.
 Sending 5, 100-byte ICMP Echos to 4.4.4.4, timeout is 2 seconds:
 Packet sent with a source address of 3.3.3.3
 !!!!!
 Success rate is 100 percent (5/5), round-trip min/avg/max = 20/47/64 ms
 Type escape sequence to abort.
 Sending 5, 100-byte ICMP Echos to 5.5.5.5, timeout is 2 seconds:
 Packet sent with a source address of 3.3.3.3
 !!!!!
 Success rate is 100 percent (5/5), round-trip min/avg/max = 36/52/72 ms
 Type escape sequence to abort.
 Sending 5, 100-byte ICMP Echos to 6.6.6.6, timeout is 2 seconds:
 Packet sent with a source address of 3.3.3.3
 !!!!!
 Success rate is 100 percent (5/5), round-trip min/avg/max = 40/56/84 ms
 Type escape sequence to abort.
 Sending 5, 100-byte ICMP Echos to 7.7.7.7, timeout is 2 seconds:
 Packet sent with a source address of 3.3.3.3
 !!!!!
 Success rate is 100 percent (5/5), round-trip min/avg/max = 40/73/136 ms
 Type escape sequence to abort.
 Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:
 Packet sent with a source address of 3.3.3.3
 !!!!!
 Success rate is 100 percent (5/5), round-trip min/avg/max = 80/81/88 ms
 R3(tcl)#

R4

Type escape sequence to abort.
 Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
 Packet sent with a source address of 4.4.4.4
 !!!!!
 Success rate is 100 percent (5/5), round-trip min/avg/max = 20/39/64 ms
 Type escape sequence to abort.
 Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
 Packet sent with a source address of 4.4.4.4
 !!!!!
 Success rate is 100 percent (5/5), round-trip min/avg/max = 8/26/40 ms
 Type escape sequence to abort.
 Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
 Packet sent with a source address of 4.4.4.4
 !!!!!
 Success rate is 100 percent (5/5), round-trip min/avg/max = 20/36/64 ms
 Type escape sequence to abort.
 Sending 5, 100-byte ICMP Echos to 4.4.4.4, timeout is 2 seconds:
 Packet sent with a source address of 4.4.4.4
 !!!!!
 Success rate is 100 percent (5/5), round-trip min/avg/max = 4/4/4 ms
 Type escape sequence to abort.
 Sending 5, 100-byte ICMP Echos to 5.5.5.5, timeout is 2 seconds:
 Packet sent with a source address of 4.4.4.4
 !!!!!
 Success rate is 100 percent (5/5), round-trip min/avg/max = 4/26/52 ms
 Type escape sequence to abort.
 Sending 5, 100-byte ICMP Echos to 6.6.6.6, timeout is 2 seconds:
 Packet sent with a source address of 4.4.4.4
 !!!!!
 Success rate is 100 percent (5/5), round-trip min/avg/max = 20/42/52 ms
 Type escape sequence to abort.
 Sending 5, 100-byte ICMP Echos to 7.7.7.7, timeout is 2 seconds:
 Packet sent with a source address of 4.4.4.4
 !!!!!
 Success rate is 100 percent (5/5), round-trip min/avg/max = 20/32/56 ms
 Type escape sequence to abort.
 Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:
 Packet sent with a source address of 4.4.4.4
 !!!!!
 Success rate is 100 percent (5/5), round-trip min/avg/max = 24/51/80 ms
 R4(tcl)#

R5

Type escape sequence to abort.
 Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
 Packet sent with a source address of 5.5.5.5
 !!!!!
 Success rate is 100 percent (5/5), round-trip min/avg/max = 32/48/64 ms
 Type escape sequence to abort.
 Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
 Packet sent with a source address of 5.5.5.5
 !!!!!
 Success rate is 100 percent (5/5), round-trip min/avg/max = 16/32/56 ms
 Type escape sequence to abort.
 Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
 Packet sent with a source address of 5.5.5.5
 !!!!!
 Success rate is 100 percent (5/5), round-trip min/avg/max = 40/60/76 ms
 Type escape sequence to abort.
 Sending 5, 100-byte ICMP Echos to 4.4.4.4, timeout is 2 seconds:
 Packet sent with a source address of 5.5.5.5
 !!!!!
 Success rate is 100 percent (5/5), round-trip min/avg/max = 4/30/64 ms
 Type escape sequence to abort.
 Sending 5, 100-byte ICMP Echos to 5.5.5.5, timeout is 2 seconds:
 Packet sent with a source address of 5.5.5.5
 !!!!!
 Success rate is 100 percent (5/5), round-trip min/avg/max = 4/4/4 ms
 Type escape sequence to abort.
 Sending 5, 100-byte ICMP Echos to 6.6.6.6, timeout is 2 seconds:
 Packet sent with a source address of 5.5.5.5
 !!!!!
 Success rate is 100 percent (5/5), round-trip min/avg/max = 8/23/44 ms
 Type escape sequence to abort.
 Sending 5, 100-byte ICMP Echos to 7.7.7.7, timeout is 2 seconds:
 Packet sent with a source address of 5.5.5.5
 !!!!!
 Success rate is 100 percent (5/5), round-trip min/avg/max = 24/40/60 ms
 Type escape sequence to abort.
 Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:
 Packet sent with a source address of 5.5.5.5
 !!!!!
 Success rate is 100 percent (5/5), round-trip min/avg/max = 20/46/64 ms
 R5(tcl)#

R6

Type escape sequence to abort.
 Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
 Packet sent with a source address of 6.6.6.6
 !!!!!
 Success rate is 100 percent (5/5), round-trip min/avg/max = 40/76/100 ms
 Type escape sequence to abort.
 Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
 Packet sent with a source address of 6.6.6.6
 !!!!!
 Success rate is 100 percent (5/5), round-trip min/avg/max = 32/48/76 ms
 Type escape sequence to abort.
 Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
 Packet sent with a source address of 6.6.6.6
 !!!!!
 Success rate is 100 percent (5/5), round-trip min/avg/max = 32/60/88 ms
 Type escape sequence to abort.
 Sending 5, 100-byte ICMP Echos to 4.4.4.4, timeout is 2 seconds:
 Packet sent with a source address of 6.6.6.6
 !!!!!
 Success rate is 100 percent (5/5), round-trip min/avg/max = 20/36/68 ms
 Type escape sequence to abort.
 Sending 5, 100-byte ICMP Echos to 5.5.5.5, timeout is 2 seconds:
 Packet sent with a source address of 6.6.6.6
 !!!!!
 Success rate is 100 percent (5/5), round-trip min/avg/max = 8/20/44 ms
 Type escape sequence to abort.
 Sending 5, 100-byte ICMP Echos to 6.6.6.6, timeout is 2 seconds:
 Packet sent with a source address of 6.6.6.6
 !!!!!
 Success rate is 100 percent (5/5), round-trip min/avg/max = 4/4/4 ms
 Type escape sequence to abort.
 Sending 5, 100-byte ICMP Echos to 7.7.7.7, timeout is 2 seconds:
 Packet sent with a source address of 6.6.6.6
 !!!!!
 Success rate is 100 percent (5/5), round-trip min/avg/max = 16/36/80 ms
 Type escape sequence to abort.
 Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:
 Packet sent with a source address of 6.6.6.6
 !!!!!
 Success rate is 100 percent (5/5), round-trip min/avg/max = 36/47/76 ms
 R6(tcl)#

R7

 Type escape sequence to abort.
 Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
 Packet sent with a source address of 7.7.7.7
 !!!!!
 Success rate is 100 percent (5/5), round-trip min/avg/max = 36/64/84 ms
 Type escape sequence to abort.
 Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
 Packet sent with a source address of 7.7.7.7
 !!!!!
 Success rate is 100 percent (5/5), round-trip min/avg/max = 20/48/76 ms
 Type escape sequence to abort.
 Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
 Packet sent with a source address of 7.7.7.7
 !!!!!
 Success rate is 100 percent (5/5), round-trip min/avg/max = 32/59/104 ms
 Type escape sequence to abort.
 Sending 5, 100-byte ICMP Echos to 4.4.4.4, timeout is 2 seconds:
 Packet sent with a source address of 7.7.7.7
 !!!!!
 Success rate is 100 percent (5/5), round-trip min/avg/max = 20/34/56 ms
 Type escape sequence to abort.
 Sending 5, 100-byte ICMP Echos to 5.5.5.5, timeout is 2 seconds:
 Packet sent with a source address of 7.7.7.7
 !!!!!
 Success rate is 100 percent (5/5), round-trip min/avg/max = 8/24/44 ms
 Type escape sequence to abort.
 Sending 5, 100-byte ICMP Echos to 6.6.6.6, timeout is 2 seconds:
 Packet sent with a source address of 7.7.7.7
 !!!!!
 Success rate is 100 percent (5/5), round-trip min/avg/max = 36/51/64 ms
 Type escape sequence to abort.
 Sending 5, 100-byte ICMP Echos to 7.7.7.7, timeout is 2 seconds:
 Packet sent with a source address of 7.7.7.7
 !!!!!
 Success rate is 100 percent (5/5), round-trip min/avg/max = 1/3/4 ms
 Type escape sequence to abort.
 Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:
 Packet sent with a source address of 7.7.7.7
 !!!!!
 Success rate is 100 percent (5/5), round-trip min/avg/max = 20/32/44 ms
 R7(tcl)#

R8

 Type escape sequence to abort.
 Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
 Packet sent with a source address of 8.8.8.8
 !!!!!
 Success rate is 100 percent (5/5), round-trip min/avg/max = 40/64/96 ms
 Type escape sequence to abort.
 Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
 Packet sent with a source address of 8.8.8.8
 !!!!!
 Success rate is 100 percent (5/5), round-trip min/avg/max = 52/64/80 ms
 Type escape sequence to abort.
 Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
 Packet sent with a source address of 8.8.8.8
 !!!!!
 Success rate is 100 percent (5/5), round-trip min/avg/max = 60/82/120 ms
 Type escape sequence to abort.
 Sending 5, 100-byte ICMP Echos to 4.4.4.4, timeout is 2 seconds:
 Packet sent with a source address of 8.8.8.8
 !!!!!
 Success rate is 100 percent (5/5), round-trip min/avg/max = 24/45/72 ms
 Type escape sequence to abort.
 Sending 5, 100-byte ICMP Echos to 5.5.5.5, timeout is 2 seconds:
 Packet sent with a source address of 8.8.8.8
 !!!!!
 Success rate is 100 percent (5/5), round-trip min/avg/max = 24/49/84 ms
 Type escape sequence to abort.
 Sending 5, 100-byte ICMP Echos to 6.6.6.6, timeout is 2 seconds:
 Packet sent with a source address of 8.8.8.8
 !!!!!
 Success rate is 100 percent (5/5), round-trip min/avg/max = 32/62/100 ms
 Type escape sequence to abort.
 Sending 5, 100-byte ICMP Echos to 7.7.7.7, timeout is 2 seconds:
 Packet sent with a source address of 8.8.8.8
 !!!!!
 Success rate is 100 percent (5/5), round-trip min/avg/max = 8/24/44 ms
 Type escape sequence to abort.
 Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:
 Packet sent with a source address of 8.8.8.8
 !!!!!
 Success rate is 100 percent (5/5), round-trip min/avg/max = 1/3/4 ms
 R8(tcl)#

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.