"Mert a csomagok sosem hazudnak."

PPPoE

PPPoE szerver és kliens konfiguráció.

Topológia:

pppoe

 

Kliens konfigurációja viszonylag egyszerű.

  • A fizikai interface-n engedélyezzük a pppoe-t
  • A fizikai interface-t hozzátársítjuk a Dialer-hez
  • Mindent a Dialer interface-n konfigurálunk.

 

Kliens konfiguráció:

 

interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 pppoe enable group global
 pppoe-client dial-pool-number 1
 !
 interface Dialer1
 ip address dhcp
 encapsulation ppp
 dialer pool 1
 dialer idle-timeout 0
 dialer persistent
 !

 

Szerver konfiguráció:

 

ip dhcp excluded-address 12.0.0.1 12.0.0.99
 !
 ip dhcp pool PPPOE
 network 12.0.0.0 255.255.255.0
 !
 bba-group pppoe global
 virtual-template 1
 !
 !
 interface FastEthernet0/0
 no ip address
 ip mtu 1492
 duplex auto
 speed auto
 pppoe enable group global
 !
 interface Virtual-Template1
 ip address 12.0.0.1 255.255.255.0
 peer default ip address dhcp-pool PPPOE
 !

 

Debugok, logok:

R2:

 

*Mar 1 00:05:01.283: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up
 *Mar 1 00:05:02.283: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
 R2#
 *Mar 1 00:06:08.803: %DIALER-6-BIND: Interface Vi2 bound to profile Di1
 *Mar 1 00:06:08.959: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to up
 R2#
 *Mar 1 00:06:10.031: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access2, changed state to up
 *Mar 1 00:07:05.315: %DHCP-6-ADDRESS_ASSIGN: Interface Dialer1 assigned DHCP address 12.0.0.102, mask 255.255.255.0, hostname R2

 

R1

 

R1#
 *Mar 1 00:05:57.535: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up
 *Mar 1 00:05:58.535: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
 R1#
 *Mar 1 00:06:07.123: PPPoE 0: I PADI R:c201.03ec.0000 L:ffff.ffff.ffff Fa0/0
 *Mar 1 00:06:07.123: Service tag: NULL Tag
 *Mar 1 00:06:07.123: PPPoE 0: O PADO, R:c200.03ec.0000 L:c201.03ec.0000 Fa0/0
 *Mar 1 00:06:07.127: Service tag: NULL Tag
 R1#
 *Mar 1 00:06:09.219: PPPoE 0: I PADR R:c201.03ec.0000 L:c200.03ec.0000 Fa0/0
 *Mar 1 00:06:09.219: Service tag: NULL Tag
 *Mar 1 00:06:09.251: PPPoE : encap string prepared
 *Mar 1 00:06:09.259: [1]PPPoE 1: Access IE handle allocated
 *Mar 1 00:06:09.263: [1]PPPoE 1: pppoe SSS switch updated
 *Mar 1 00:06:09.263: [1]PPPoE 1: AAA unique ID allocated
 *Mar 1 00:06:09.263: [1]PPPoE 1: No AAA accounting method list
 *Mar 1 00:06:09.267: [1]PPPoE 1: Service request sent to SSS
 *Mar 1 00:06:09.267: [1]PPPoE 1: Created, Service: None R:c200.03ec.0000 L:c201.03ec.0000 Fa0/0
 *Mar 1 00:06:09.271: [1]PPPoE 1: State NAS_PORT_POLICY_INQUIRY Event SSS_LOCAL
 R1#
 *Mar 1 00:06:09.271: [1]PPPoE 1: O PADS R:c201.03ec.0000 L:c200.03ec.0000 Fa0/0
 *Mar 1 00:06:09.279: [1]PPPoE 1: State PPP_START Event DYN_BIND
 *Mar 1 00:06:09.279: [1]PPPoE 1: data path set to PPP
 *Mar 1 00:06:09.495: [1]PPPoE 1: State LCP_NEGOTIATION Event PPP_LOCAL
 *Mar 1 00:06:09.495: PPPoE 1/SB: Sent vtemplate request on base Vi1
 *Mar 1 00:06:09.727: [1]PPPoE 1: State VACCESS_REQUESTED Event VA_RESP
 *Mar 1 00:06:09.731: [1]PPPoE 1: Vi1.1 interface obtained
 *Mar 1 00:06:09.731: [1]PPPoE 1: State PTA_BINDING Event STAT_BIND
 *Mar 1 00:06:09.735: [1]PPPoE 1: data path set to Virtual Acess
 *Mar 1 00:06:09.735: [1]PPPoE 1: Connected PTA
 

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.