"Mert a csomagok sosem hazudnak."

Az első MPLS felhőm

Ma összeraktam életem első MPLS felhőjét! Az MPLS VPN egyelőre kifogott rajtam, de nem adom fel, és valamikor megcsinálom. Azért a VRF-ekbe és BGP address-family-kba bele lehet ám keveredni rendesen.

mpls_1

PE1

!
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname PE1
!
boot-start-marker
boot-end-marker
!
logging discriminator CDP severity drops 4 mnemonics drops DUPLEX_MISMATCH
logging console discriminator CDP
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
!
no ip domain lookup
ip domain name lab.local
!
mpls label protocol ldp
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
log config
hidekeys
!
!
!
!
!
!
!
!
interface Loopback1
ip address 2.2.2.2 255.255.255.0
ip ospf 1 area 0
!
!
interface FastEthernet0/1
ip address 10.0.23.2 255.255.255.0
ip ospf 1 area 0
duplex auto
speed auto
mpls ip
!
interface FastEthernet1/0
ip address 10.0.24.2 255.255.255.0
ip ospf 1 area 0
duplex auto
speed auto
mpls ip
!
router ospf 1
log-adjacency-changes
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
!
end

PE2

!
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname PE2
!
boot-start-marker
boot-end-marker
!
logging discriminator CDP severity drops 4 mnemonics drops DUPLEX_MISMATCH
logging console discriminator CDP
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
!
no ip domain lookup
ip domain name lab.local
!
mpls label protocol ldp
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
log config
hidekeys
!
!
!
!
!
!
!
!
interface Loopback0
ip address 5.5.5.5 255.255.255.0
ip ospf 1 area 0
!
interface FastEthernet0/0
ip address 10.0.45.5 255.255.255.0
ip ospf 1 area 0
duplex auto
speed auto
mpls ip
!
interface FastEthernet1/0
ip address 10.0.35.5 255.255.255.0
ip ospf 1 area 0
duplex auto
speed auto
mpls ip
!
router ospf 1
log-adjacency-changes
!
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
!
end

R3

!
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
logging discriminator CDP severity drops 4 mnemonics drops DUPLEX_MISMATCH
logging console discriminator CDP
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
ip domain name lab.local
!
mpls label protocol ldp
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
log config
hidekeys
!
!
!
!
!
!
!
!
interface Loopback0
ip address 3.3.3.3 255.255.255.0
ip ospf 1 area 0
!
interface FastEthernet0/0
ip address 10.0.23.3 255.255.255.0
ip ospf 1 area 0
duplex auto
speed auto
mpls ip
!
interface FastEthernet0/1
ip address 10.0.35.3 255.255.255.0
ip ospf 1 area 0
duplex auto
speed auto
mpls ip
!
router ospf 1
log-adjacency-changes
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
!
end

R4

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R4
!
boot-start-marker
boot-end-marker
!
logging discriminator CDP severity drops 4 mnemonics drops DUPLEX_MISMATCH
logging console discriminator CDP
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
ip domain name lab.local
!
mpls label protocol ldp
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
log config
hidekeys
!
!
!
!
!
!
!
!
interface Loopback1
ip address 4.4.4.4 255.255.255.0
ip ospf 1 area 0
!
interface FastEthernet0/0
ip address 10.0.24.4 255.255.255.0
ip ospf 1 area 0
duplex auto
speed auto
mpls ip
!
interface FastEthernet0/1
ip address 10.0.45.4 255.255.255.0
ip ospf 1 area 0
duplex auto
speed auto
mpls ip
!
router ospf 1
log-adjacency-changes
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
!
end

Nagyon király, látszanak az LDP neighbor-ök és az MPLS route-k.

PE2#sh mpls forwarding-table
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop
tag    tag or VC   or Tunnel Id      switched   interface
16     16          10.0.24.0/24      0          Fa1/0      10.0.35.3
17     Pop tag     10.0.23.0/24      0          Fa1/0      10.0.35.3
18     19          2.2.2.2/32        0          Fa1/0      10.0.35.3
19     Untagged    4.4.4.4/32        0          Fa0/0      10.0.45.4
20     Untagged    3.3.3.3/32        0          Fa1/0      10.0.35.3
PE2#sh mpls ldp ne
Peer LDP Ident: 4.4.4.4:0; Local LDP Ident 5.5.5.5:0
TCP connection: 4.4.4.4.646 – 5.5.5.5.58276
State: Oper; Msgs sent/rcvd: 19/19; Downstream
Up time: 00:07:05
LDP discovery sources:
FastEthernet0/0, Src IP addr: 10.0.45.4
Addresses bound to peer LDP Ident:
10.0.24.4       4.4.4.4         10.0.45.4
Peer LDP Ident: 3.3.3.3:0; Local LDP Ident 5.5.5.5:0
TCP connection: 3.3.3.3.646 – 5.5.5.5.32455
State: Oper; Msgs sent/rcvd: 14/14; Downstream
Up time: 00:02:46
LDP discovery sources:
FastEthernet1/0, Src IP addr: 10.0.35.3
Addresses bound to peer LDP Ident:
10.0.23.3       3.3.3.3         10.0.35.3
PE2#
Folyt köv.

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.