[REQ] OSPF – NSSA – default-information-originate

Volt egy kérés még egy régi labhoz kommentben, hogy tisztázzuk kicsit az NSSA default-information originate részt (az eredeti bejegyzés itt található).

Ezen a topológián vezetem le a dolgot:

A transit link subnetek a szokásosak (R1-R2 között 10.0.12.0/24, R2-R3 között 10.0.23.0/24 stb.)

EIGRP-ből fogunk OSPF-be redistributálni az 1-es NSSA Area-n keresztül, és megvizsgáljuk, hogyan látszik ez a többi Area-ban.

R5-n egy default route-t látunk (totally stubby) R2-től, R2-R1-R3 IA route-kat lát a többi Area-ból.

Fontos, hogy:
  • Stub – nincs T4, T5 LSA
  • Totally Stub – nincs T3, T4, T5 LSA (nem lát IA route-kat)
  • NSSA – nincs T4, T5 LSA (de van T7 a redisztribúcióhoz)
  • Totally NSSA – nincs T3, T4, T5 LSA (de van T7 a redisztribúcióhoz)

 

ABR NSSA és más area között T7->T5 konverziót csinál!

Csináljuk meg a redistribution-t R3-n:

R3#
R3#
R3#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R3(config)#router ospf 1
R3(config-router)#redist
R3(config-router)#redistribute eigrp 1 subnets
R3(config-router)#^Z
R3#
*Mar 1 00:27:31.911: %SYS-5-CONFIG_I: Configured from console by console
R3#

R1-en már meg is jelent a 10.0.34.0/24 N2 route-ként (NSSA E2 route-ként):

R1#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
 D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
 N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
 E1 - OSPF external type 1, E2 - OSPF external type 2
 i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
 ia - IS-IS inter area, * - candidate default, U - per-user static route
 o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
10.0.0.0/24 is subnetted, 4 subnets
C 10.0.12.0 is directly connected, Serial0/1
C 10.0.13.0 is directly connected, Serial0/0
O IA 10.0.25.0 [110/128] via 10.0.12.2, 00:16:13, Serial0/1
O N2 10.0.34.0 [110/20] via 10.0.13.3, 00:02:35, Serial0/0

Mivel R1 az ABR az 1-es NSSA és Area 0 között, Area0-ban R2 már E2 route-ként látja majd a 10.0.34.0/24-et:

R2#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
 D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
 N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
 E1 - OSPF external type 1, E2 - OSPF external type 2
 i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
 ia - IS-IS inter area, * - candidate default, U - per-user static route
 o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
10.0.0.0/24 is subnetted, 4 subnets
C 10.0.12.0 is directly connected, Serial0/0
O IA 10.0.13.0 [110/128] via 10.0.12.1, 00:17:10, Serial0/0
C 10.0.25.0 is directly connected, Serial0/1
O E2 10.0.34.0 [110/20] via 10.0.12.1, 00:03:37, Serial0/0


Vegyétek észre, hogy:

  • A metric 20 – az OSPF redistribution seed metric-ek miatt (BGP: 1, OSPF: ugyanaz, minden más 20)
  • E2/N2: a costhoz nem adja hozzá a belső costokat (ezért marad 20 R2-n is)

R5 totally stub area-ban van, így nem tud a default route-n kívül továbbra sem semmit:

R5#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
 D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
 N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
 E1 - OSPF external type 1, E2 - OSPF external type 2
 i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
 ia - IS-IS inter area, * - candidate default, U - per-user static route
 o - ODR, P - periodic downloaded static route
Gateway of last resort is 10.0.25.2 to network 0.0.0.0
10.0.0.0/24 is subnetted, 1 subnets
C 10.0.25.0 is directly connected, Serial0/0
O*IA 0.0.0.0/0 [110/65] via 10.0.25.2, 00:18:14, Serial0/0

R3 fog hirdetni default route-t. Mivel most EIGRP-be nem hirdettünk defaultot, csináljunk egy statikus route-t, amely 10.0.34.4-re mutat, és ezt hirdessük bele OSPF-be:

R3#
R3#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R3(config)#ip route 0.0.0.0 0.0.0.0 10.0.34.4
R3(config)#router ospf 1
R3(config-router)#area 1 nssa def
R3(config-router)#area 1 nssa default-information-originate
R3(config-router)#^Z
R3#
*Mar 1 00:34:52.355: %SYS-5-CONFIG_I: Configured from console by console
R3#
*Mar 1 00:34:52.355: %SYS-5-CONFIG_I: Configured from console by console
R3#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
 D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
 N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
 E1 - OSPF external type 1, E2 - OSPF external type 2
 i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
 ia - IS-IS inter area, * - candidate default, U - per-user static route
 o - ODR, P - periodic downloaded static route
Gateway of last resort is 10.0.34.4 to network 0.0.0.0
10.0.0.0/24 is subnetted, 4 subnets
O IA 10.0.12.0 [110/128] via 10.0.13.1, 00:01:04, Serial0/1
C 10.0.13.0 is directly connected, Serial0/1
O IA 10.0.25.0 [110/192] via 10.0.13.1, 00:01:04, Serial0/1
C 10.0.34.0 is directly connected, Serial0/0
S* 0.0.0.0/0 [1/0] via 10.0.34.4


Nézzük a többi routeren mi változott:

R1#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
 D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
 N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
 E1 - OSPF external type 1, E2 - OSPF external type 2
 i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
 ia - IS-IS inter area, * - candidate default, U - per-user static route
 o - ODR, P - periodic downloaded static route
Gateway of last resort is 10.0.13.3 to network 0.0.0.0
10.0.0.0/24 is subnetted, 4 subnets
C 10.0.12.0 is directly connected, Serial0/1
C 10.0.13.0 is directly connected, Serial0/0
O IA 10.0.25.0 [110/128] via 10.0.12.2, 00:01:45, Serial0/1
O N2 10.0.34.0 [110/20] via 10.0.13.3, 00:01:30, Serial0/0
O*N2 0.0.0.0/0 [110/1] via 10.0.13.3, 00:00:11, Serial0/0

R2#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
 D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
 N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
 E1 - OSPF external type 1, E2 - OSPF external type 2
 i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
 ia - IS-IS inter area, * - candidate default, U - per-user static route
 o - ODR, P - periodic downloaded static route
Gateway of last resort is 10.0.12.1 to network 0.0.0.0
10.0.0.0/24 is subnetted, 4 subnets
C 10.0.12.0 is directly connected, Serial0/0
O IA 10.0.13.0 [110/128] via 10.0.12.1, 00:03:00, Serial0/0
C 10.0.25.0 is directly connected, Serial0/1
O E2 10.0.34.0 [110/20] via 10.0.12.1, 00:02:54, Serial0/0
O*E2 0.0.0.0/0 [110/1] via 10.0.12.1, 00:01:41, Serial0/0

R5#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
 D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
 N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
 E1 - OSPF external type 1, E2 - OSPF external type 2
 i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
 ia - IS-IS inter area, * - candidate default, U - per-user static route
 o - ODR, P - periodic downloaded static route
Gateway of last resort is 10.0.25.2 to network 0.0.0.0
10.0.0.0/24 is subnetted, 1 subnets
C 10.0.25.0 is directly connected, Serial0/0
O*IA 0.0.0.0/0 [110/65] via 10.0.25.2, 00:24:27, Serial0/0

R1 és R2 is meghallja a default route-t, R1 N2-ként (NSSA!), R2 E2-ként (normal area, és az ABR már T7 -> T5 átalakítást végzett), R5 továbbra sem változik, hiszen totally stubby area.

Remélem érthetőbb lett a dolog, kérdések persze jöhetnek kommentben!

A running-configok, ha valaki kipróbálná GNS3ban:

R1#sh run
Building configuration...
Current configuration : 1013 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
 log config
 hidekeys
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 10.0.13.1 255.255.255.0
 clock rate 2000000
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 ip address 10.0.12.1 255.255.255.0
 clock rate 2000000
!
router ospf 1
 log-adjacency-changes
 area 1 nssa
 network 10.0.12.0 0.0.0.255 area 0
 network 10.0.13.0 0.0.0.255 area 1
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
!
!
end

R2#sh run
Building configuration...
Current configuration : 1158 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
 log config
 hidekeys
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 10.0.12.2 255.255.255.0
 clock rate 2000000
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 ip address 10.0.25.2 255.255.255.0
 clock rate 2000000
!
interface Serial0/2
 no ip address
 shutdown
 clock rate 2000000
!
interface Serial0/3
 no ip address
 shutdown
 clock rate 2000000
!
router ospf 1
 log-adjacency-changes
 area 2 stub no-summary
 network 10.0.12.0 0.0.0.255 area 0
 network 10.0.25.0 0.0.0.255 area 2
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
!
!
end

R3#sh run
Building configuration...
Current configuration : 1132 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
 log config
 hidekeys
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 10.0.34.3 255.255.255.0
 clock rate 2000000
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 ip address 10.0.13.3 255.255.255.0
 clock rate 2000000
!
router eigrp 1
 network 10.0.34.0 0.0.0.255
 auto-summary
!
router ospf 1
 log-adjacency-changes
 area 1 nssa default-information-originate
 redistribute eigrp 1 subnets
 network 10.0.13.0 0.0.0.255 area 1
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 10.0.34.4
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
!
!
end

R4#sh run
Building configuration...
Current configuration : 938 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R4
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
 log config
 hidekeys
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 10.0.34.4 255.255.255.0
 clock rate 2000000
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 no ip address
 shutdown
 clock rate 2000000
!
router eigrp 1
 network 10.0.34.0 0.0.0.255
 auto-summary
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
!
!
end

R5#sh run
Building configuration...
Current configuration : 966 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R5
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
 log config
 hidekeys
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 10.0.25.5 255.255.255.0
 clock rate 2000000
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 no ip address
 shutdown
 clock rate 2000000
!
router ospf 1
 log-adjacency-changes
 area 2 stub
 network 10.0.25.0 0.0.0.255 area 2
!
ip forward-protocol nd
!
!

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.

2 thoughts on “[REQ] OSPF – NSSA – default-information-originate”