SWITCH Lab 1 – VLAN, VTP, EtherChannel


Adott tehát a topológia:

Az alábbiakat fogjuk végrehajtani:

  • Trunkok beállítása
  • VTP beállítása – domain: TSHOOT, version 2, pass: cisco
  • VLAN 2 – VTP_TESZT vlan létrehozása
  • 2 db Etherchannel felkonfigurálása
    • Fa0/1, Fa0/2 –> LACP, DSW1 az active, ASW1 a passive, Layer2-es EtherChannel
    • Fa0/47, Fa0/48 –> PaGP, DSW1 és ASW1 “on”, Layer3-as Etherchannel, IP: 10.0.0.0 /30

Először megmutatom az alap konfigot DSW1-en, az alapokkal indulunk:

User Access Verification
Username: tshoot
Password: 
DSW1-Cat3560#sh run
Building configuration...
Current configuration : 2692 bytes
!
! Last configuration change at 12:07:17 UTC Mon Apr 2 2012 by tshoot
! NVRAM config last updated at 11:30:16 UTC Mon Apr 2 2012 by tshoot
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname DSW1-Cat3560
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$UZSZ$95Ls01Ovmg/Ld3XnImFwO1
!
username tshoot privilege 15 password 0 cisco
no aaa new-model
system mtu routing 1500
vtp domain tshoot_lab
 
--More--  
vtp mode transparent
ip subnet-zero
!
!
!
!
!
!
!
!
!
!
spanning-tree mode rapid-pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
vlan 50 
!
!
!
!
interface FastEthernet0/1

 --More-- 
 !
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
 
--More--  
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24

 --More--  
!
interface FastEthernet0/25
!
interface FastEthernet0/26
!
interface FastEthernet0/27
!
interface FastEthernet0/28
!
interface FastEthernet0/29
!
interface FastEthernet0/30
!
interface FastEthernet0/31
!
interface FastEthernet0/32
!
interface FastEthernet0/33
!
interface FastEthernet0/34
!
interface FastEthernet0/35
!
 
--More--  
interface FastEthernet0/36
!
interface FastEthernet0/37
!
interface FastEthernet0/38
!
interface FastEthernet0/39
!
interface FastEthernet0/40
!
interface FastEthernet0/41
!
interface FastEthernet0/42
!
interface FastEthernet0/43
!
interface FastEthernet0/44
!
interface FastEthernet0/45
!
interface FastEthernet0/46
!
interface FastEthernet0/47
 
--More-- 
 !
interface FastEthernet0/48
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface GigabitEthernet0/3
!
interface GigabitEthernet0/4
!
interface Vlan1
 ip address 192.168.1.1 255.255.255.252
!
ip classless
ip http server
ip http secure-server
!
!
!
control-plane
!
banner motd ^C

 --More-- 
 
 .___ .__ __ 
 __| _/ |__| ______ _/ |_ _______ 
 / __ | | | / ___/  __ _ __ 
/ /_/ | | | ___  | | | | /
____ | |__| /____ > |__| |__| 
 / /

^C
!
line con 0
 exec-timeout 0 0
 logging synchronous
 login local
line vty 0 4
 login
line vty 5 15
 login
!
end

Nézzük meg CDP-vel, hogy minden link látszik -e ASW1 felé:

DSW1-Cat3560#sh cdp ne
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
 S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone
Device ID Local Intrfce Holdtme Capability Platform Port ID
ASW1-Cat3550 Fas 0/48 177 S I WS-C3550- Fas 0/48
ASW1-Cat3550 Fas 0/47 177 S I WS-C3550- Fas 0/47
ASW1-Cat3550 Fas 0/2 177 S I WS-C3550- Fas 0/2
ASW1-Cat3550 Fas 0/1 177 S I WS-C3550- Fas 0/1

L2-ben rendben vagyunk. Nézzünk egy VLAN database-t és egy VTP statust DSW1-en:

DSW1-Cat3560#sh vl b
VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 default active Fa0/3, Fa0/4, Fa0/5, Fa0/6
 Fa0/7, Fa0/8, Fa0/9, Fa0/10
 Fa0/11, Fa0/12, Fa0/13, Fa0/14
 Fa0/15, Fa0/16, Fa0/17, Fa0/18
 Fa0/19, Fa0/20, Fa0/21, Fa0/22
 Fa0/23, Fa0/24, Fa0/25, Fa0/26
 Fa0/27, Fa0/28, Fa0/29, Fa0/30
 Fa0/31, Fa0/32, Fa0/33, Fa0/34
 Fa0/35, Fa0/36, Fa0/37, Fa0/38
 Fa0/39, Fa0/40, Fa0/41, Fa0/42
 Fa0/43, Fa0/44, Fa0/45, Fa0/46
 Gi0/1, Gi0/2, Gi0/3, Gi0/4
50 VLAN0050 active 
1002 fddi-default act/unsup 
1003 trcrf-default act/unsup 
1004 fddinet-default act/unsup 
1005 trbrf-default act/unsup 
DSW1-Cat3560#sh vtp status
VTP Version : running VTP2
Configuration Revision : 0
Maximum VLANs supported locally : 1005
Number of existing VLANs : 6
VTP Operating Mode : Transparent
VTP Domain Name : tshoot_lab
VTP Pruning Mode : Enabled
VTP V2 Mode : Enabled
VTP Traps Generation : Disabled
MD5 digest : 0xCB 0xCD 0xC1 0x73 0x74 0x91 0x6D 0xF9 
Configuration last modified by 192.168.1.1 at 4-1-93 05:22:07

ASW1-en:

ASW1-Cat3550#sh vl b
VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 default active Fa0/3, Fa0/4, Fa0/5, Fa0/6
 Fa0/7, Fa0/8, Fa0/9, Fa0/10
 Fa0/11, Fa0/12, Fa0/13, Fa0/14
 Fa0/15, Fa0/16, Fa0/17, Fa0/18
 Fa0/19, Fa0/20, Fa0/21, Fa0/22
 Fa0/23, Fa0/24, Fa0/25, Fa0/26
 Fa0/27, Fa0/28, Fa0/29, Fa0/30
 Fa0/31, Fa0/32, Fa0/33, Fa0/34
 Fa0/35, Fa0/36, Fa0/37, Fa0/38
 Fa0/39, Fa0/40, Fa0/41, Fa0/42
 Fa0/43, Fa0/44, Fa0/45, Fa0/46
 Gi0/1, Gi0/2
2 VLAN0002 active 
10 VLAN0010 active 
20 VLAN0020 active 
30 VLAN0030 active 
40 VLAN0040 active 
50 VLAN0050 active 
60 VLAN0060 active 
100 VLAN0100 active
VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
999 NATIVE-TEST active 
1002 fddi-default act/unsup 
1003 trcrf-default act/unsup 
1004 fddinet-default act/unsup 
1005 trbrf-default act/unsup 
ASW1-Cat3550#sh vtp status
VTP Version : 2
Configuration Revision : 10
Maximum VLANs supported locally : 1005
Number of existing VLANs : 14
VTP Operating Mode : Client
VTP Domain Name : lab
VTP Pruning Mode : Enabled
VTP V2 Mode : Enabled
VTP Traps Generation : Disabled
MD5 digest : 0x0C 0x3C 0x4B 0x38 0x9B 0xE0 0x1A 0xAF 
Configuration last modified by 192.168.1.1 at 4-1-93 05:22:07

Félkövérrel kiemeltem a lényeget: nem atzonosak a VTP domainek, nem azonos a jelszó, az egyik switch transparent módban van, és mivel a VLAN-ok is különböznek, nem biztosan működik a VTP.

A VTP működéséhez az alábbiak kellenek:

  • Trunk a switchek között
  • Azonos domain name
  • Azonos VTP version
  • Azonos VTP password
  • Ne legyen transparent módban (transparent módban továbbítja a VTP kereteket, de nem frissíti a VLAN adatbázisát, egyfajta “relay”-ként működik a switch).

Nézzük a trunk-ök rendben vannak -e:

DSW1-Cat3560#sh int trunk
Port Mode Encapsulation Status Native vlan
Fa0/1 auto n-isl trunking 1
Fa0/2 auto n-isl trunking 1
Fa0/47 auto n-isl trunking 1
Fa0/48 auto n-isl trunking 1
Port Vlans allowed on trunk
Fa0/1 1-4094
Fa0/2 1-4094
Fa0/47 1-4094
Fa0/48 1-4094
Port Vlans allowed and active in management domain
Fa0/1 1,50
Fa0/2 1,50
Fa0/47 1,50
Fa0/48 1,50
Port Vlans in spanning tree forwarding state and not pruned
Fa0/1 1,50
Fa0/2 50
Fa0/47 50
Port Vlans in spanning tree forwarding state and not pruned

Hmm… ISL a trunk encapsulation. Ez működik, de jobban szeretjük a dot1q-t (standard, az ISL Cisco fejlesztés). Miért is lett ISL? Azért, mert ha mindkét switch támogatja az ISL-t, azt választják, ha az egyik nem, akkor a 802.1q-t (ha az egyik switch 2960-as lenne, dot1q lenne a trunk, mivel a 2960-as nem támogatja az ISL-t).

A trunk azért állt össze, mert ASW1-en minden port dynamic desirable (alapértelmezett a 3550-esen), és:

  • dynamic desirable + auto = trunk
  • auto + auto = access
  • access + dynamic desirable = access
  • dynamic desirable + dynamic desirable = trunk

Állítsuk át dot1q-ra, kézzel trunk-re, és legyen a native VLAN a 999-es:

DSW1-Cat3560#conf t
Enter configuration commands, one per line. End with CNTL/Z.
DSW1-Cat3560(config)#int ra fa0/1 - 2 , fa0/47 - 48
DSW1-Cat3560(config-if-range)#sw trunk en dot1q
DSW1-Cat3560(config-if-range)#sw mo trunk
DSW1-Cat3560(config-if-range)#^Z
DSW1-Cat3560#
Apr 2 18:49:20.817: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to down
Apr 2 18:49:20.817: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to down
Apr 2 18:49:20.826: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/2, changed state to down
Apr 2 18:49:20.834: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/47, changed state to down
Apr 2 18:49:20.834: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0
DSW1-Cat3560#/48, changed state to down
Apr 2 18:49:21.790: %SYS-5-CONFIG_I: Configured from console by tshoot on console
DSW1-Cat3560#
Apr 2 18:49:23.879: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up
Apr 2 18:49:23.896: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/2, changed state to up
Apr 2 18:49:23.913: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/47, changed state to up
Apr 2 18:49:23.929: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/48, changed state to up
DSW1-Cat3560#
Apr 2 18:49:25.087: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to up
DSW1-Cat3560#
DSW1-Cat3560#
DSW1-Cat3560#
DSW1-Cat3560#sh int trunk
Port Mode Encapsulation Status Native vlan
Fa0/1 on 802.1q trunking 1
Fa0/2 on 802.1q trunking 1
Fa0/47 on 802.1q trunking 1
Fa0/48 on 802.1q trunking 1
Port Vlans allowed on trunk
Fa0/1 1-4094
Fa0/2 1-4094
Fa0/47 1-4094
Fa0/48 1-4094
Port Vlans allowed and active in management domain
Fa0/1 1,50
Fa0/2 1,50
Fa0/47 1,50
Fa0/48 1,50
Port Vlans in spanning tree forwarding state and not pruned
Fa0/1 1
Fa0/2 none
Fa0/47 none
Port Vlans in spanning tree forwarding state and not pruned
Fa0/48 none

A trunk dot1q lett. Az alábbi parancsokat használtam:

  • switchport trunk encapsulation dot1q: a trunk encapsulation-t dot1q-ra állítja
  • switchport mode trunk: az interface-t trunk módba állítja – ettől még a DTP (Dynamic Trunk Protocol) működik!

Állítsuk át a native vlan-t 999-re:
DSW1-Cat3560#conf t
Enter configuration commands, one per line. End with CNTL/Z.
DSW1-Cat3560(config)#vlan 999
DSW1-Cat3560(config-vlan)#name NATIVE
DSW1-Cat3560(config-vlan)#exit
DSW1-Cat3560(config)#int ra fa0/1 - 2 , fas0/47 - 48
DSW1-Cat3560(config-if-range)#sw trunk native vlan 999
DSW1-Cat3560(config-if-range)#^Z
DSW1-Cat3560#
Apr 2 18:50:11.744: %SYS-5-CONFIG_I: Configured from console by tshoot on console
DSW1-Cat3560#
Apr 2 18:50:42.505: %SPANTREE-2-RECV_PVID_ERR: Received BPDU with inconsistent peer vlan id 1 on FastEthernet0/1 VLAN999.
Apr 2 18:50:42.505: %SPANTREE-2-BLOCK_PVID_PEER: Blocking FastEthernet0/1 on VLAN0001. Inconsistent peer vlan.
Apr 2 18:50:42.505: %SPANTREE-2-BLOCK_PVID_LOCAL: Blocking FastEthernet0/1 on VLAN0999. Inconsistent local vlan.
Apr 2 18:50:42.514: %SPANTREE-2-RECV_PVID_ERR: Received BPDU with inconsistent peer vlan id 1 on FastEthernet0/2 VLAN999.
Apr 2 18:50:42.514: %SPANTREE-2-
DSW1-Cat3560#BLOCK_PVID_PEER: Blocking FastEthernet0/2 on VLAN0001. Inconsistent peer vlan.
Apr 2 18:50:42.522: %SPANTREE-2-BLOCK_PVID_LOCAL: Blocking FastEthernet0/2 on VLAN0999. Inconsistent local vlan.
Apr 2 18:50:42.522: %SPANTREE-2-RECV_PVID_ERR: Received BPDU with inconsistent peer vlan id 1 on FastEthernet0/47 VLAN999.
Apr 2 18:50:42.522: %SPANTREE-2-BLOCK_PVID_PEER: Blocking FastEthernet0/47 on VLAN0001. Inconsistent peer vlan.
Apr 2 18:50:42.522: %SPANTREE-2-BLOCK_PVID_LOCAL: Blocking FastEthernet0/47 
DSW1-Cat3560#on VLAN0999. Inconsistent local vlan.
Apr 2 18:50:42.522: %SPANTREE-2-RECV_PVID_ERR: Received BPDU with inconsistent peer vlan id 1 on FastEthernet0/48 VLAN999.
Apr 2 18:50:42.522: %SPANTREE-2-BLOCK_PVID_PEER: Blocking FastEthernet0/48 on VLAN0001. Inconsistent peer vlan.
Apr 2 18:50:42.522: %SPANTREE-2-BLOCK_PVID_LOCAL: Blocking FastEthernet0/48 on VLAN0999. Inconsistent local vlan.
Apr 2 18:50:43.512: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to down
DSW1-Cat3560#
Apr 2 18:51:12.453: %SPANTREE-2-UNBLOCK_CONSIST_PORT: Unblocking FastEthernet0/1 on VLAN0001. Port consistency restored.
Apr 2 18:51:12.453: %SPANTREE-2-UNBLOCK_CONSIST_PORT: Unblocking FastEthernet0/1 on VLAN0999. Port consistency restored.
Apr 2 18:51:12.453: %SPANTREE-2-UNBLOCK_CONSIST_PORT: Unblocking FastEthernet0/2 on VLAN0001. Port consistency restored.
Apr 2 18:51:12.453: %SPANTREE-2-UNBLOCK_CONSIST_PORT: Unblocking FastEthernet0/2 on VLAN0999. Port consistency restored.
Apr 2 18:51:12.4
DSW1-Cat3560#53: %SPANTREE-2-UNBLOCK_CONSIST_PORT: Unblocking FastEthernet0/47 on VLAN0001. Port consistency restored.
Apr 2 18:51:12.453: %SPANTREE-2-UNBLOCK_CONSIST_PORT: Unblocking FastEthernet0/47 on VLAN0999. Port consistency restored.
Apr 2 18:51:12.453: %SPANTREE-2-UNBLOCK_CONSIST_PORT: Unblocking FastEthernet0/48 on VLAN0001. Port consistency restored.
Apr 2 18:51:12.453: %SPANTREE-2-UNBLOCK_CONSIST_PORT: Unblocking FastEthernet0/48 on VLAN0999. Port consistency restored.
DSW1-Cat3560#
Apr 2 18:51:14.466: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to up
DSW1-Cat3560#
DSW1-Cat3560#
DSW1-Cat3560#
DSW1-Cat3560#
DSW1-Cat3560#sh int trunk
Port Mode Encapsulation Status Native vlan
Fa0/1 on 802.1q trunking 999
Fa0/2 on 802.1q trunking 999
Fa0/47 on 802.1q trunking 999
Fa0/48 on 802.1q trunking 999
...

Látható, hogy amint a native vlan-t átállítottam, működésbe lépett a Spanning Tree. Ennek oka:

%SPANTREE-2-RECV_PVID_ERR : Received BPDU with inconsistent peer vlan id [dec] on [chars] [chars].

Explanation    The specified interface has received an SSTP BPDU that is tagged with a VLAN ID that does not match the VLAN ID on which the BPDU was received. This condition occurs when the native VLAN is not consistently configured on both ends of a 802.1Q trunk.

Akkor állt helyre a rend, amikor a másik switchen is beállítottam a native vlan-t (999).

 

Következőnek tegyük helyre a VTP-t:

  • domain: TSHOOT
  • password: cisco
  • version: 2
DSW1-Cat3560#
DSW1-Cat3560#
DSW1-Cat3560#conf t
Enter configuration commands, one per line. End with CNTL/Z.
DSW1-Cat3560(config)#vtp domain TSHOOT
Changing VTP domain name from LAB2 to TSHOOT
DSW1-Cat3560(config)#vt
Apr 2 18:53:22.829: %SW_VLAN-6-VTP_DOMAIN_NAME_CHG: VTP domain name changed to TSHOOT.
DSW1-Cat3560(config)#vtp password cisco
Setting device VLAN database password to cisco
DSW1-Cat3560(config)#vtp version 2
VTP mode already in V2.
DSW1-Cat3560(config)#^Z
DSW1-Cat3560#
Apr 2 18:53:32.165: %SYS-5-CONFIG_I: Configured from console by tshoot on console
DSW1-Cat3560#
DSW1-Cat3560#
DSW1-Cat3560#sh vtp status
VTP Version : running VTP2
Configuration Revision : 0
Maximum VLANs supported locally : 1005
Number of existing VLANs : 7
VTP Operating Mode : Server
VTP Domain Name : TSHOOT
VTP Pruning Mode : Enabled
VTP V2 Mode : Enabled
VTP Traps Generation : Disabled
MD5 digest : 0xB4 0x65 0xFD 0xCF 0xE5 0x3C 0xE1 0xA5 
Configuration last modified by 192.168.1.1 at 4-2-12 18:49:55
Local updater ID is 192.168.1.1 on interface Vl1 (lowest numbered VLAN interface found)

ASW1-Cat3550#
ASW1-Cat3550#conf t
Enter configuration commands, one per line. End with CNTL/Z.
ASW1-Cat3550(config)#vtp domain TSHOOT
Changing VTP domain name from LAB to TSHOOT
ASW1-Cat3550(config)#vtp version 2
VTP mode already in V2.
ASW1-Cat3550(config)#vtp password cisco
Setting device VLAN database password to cisco
ASW1-Cat3550(config)#vtp mode client
Setting device to VTP CLIENT mode.
ASW1-Cat3550(config)#^Z
ASW1-Cat3550#
ASW1-Cat3550#
ASW1-Cat3550#
07:55:54: %SYS-5-CONFIG_I: Configured from console by tshoot on console

Próbáljuk ki, hozzunk létre egy VLAN2-t DSW1-en, és nézzük meg, lefrissül -e:

DSW1-Cat3560(config)#vlan 20
DSW1-Cat3560(config-vlan)#name VTP_TESZT
DSW1-Cat3560(config-vlan)#^Z
DSW1-Cat3560#
ASW1-Cat3550#sh vl b
VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 default active Fa0/3, Fa0/4, Fa0/5, Fa0/6
 Fa0/7, Fa0/8, Fa0/9, Fa0/10
 Fa0/11, Fa0/12, Fa0/13, Fa0/14
 Fa0/15, Fa0/16, Fa0/17, Fa0/18
 Fa0/19, Fa0/20, Fa0/21, Fa0/22
 Fa0/23, Fa0/24, Fa0/25, Fa0/26
 Fa0/27, Fa0/28, Fa0/29, Fa0/30
 Fa0/31, Fa0/32, Fa0/33, Fa0/34
 Fa0/35, Fa0/36, Fa0/37, Fa0/38
 Fa0/39, Fa0/40, Fa0/41, Fa0/42
 Fa0/43, Fa0/44, Fa0/45, Fa0/46
 Gi0/1, Gi0/2
2 VTP_TESZT active 
50 VLAN0050 active 
999 NATIVE active 
1002 fddi-default act/unsup 
1003 trcrf-default act/unsup 
1004 fddinet-default act/unsup 
1005 trbrf-default act/unsup 
ASW1-Cat3550#
ASW1-Cat3550#
ASW1-Cat3550#

 

Csináljunk egy Layer-2-es LACP EtherChannel-t, ahol DSW1 az active, ASW2 a passive (Fa0/1 és Fa0/2 portokkal):

 
DSW1-Cat3560#
DSW1-Cat3560#
DSW1-Cat3560#conf t
Enter configuration commands, one per line. End with CNTL/Z.
DSW1-Cat3560(config)#int fa0/1
DSW1-Cat3560(config-if)#channel-protocol lacp
DSW1-Cat3560(config-if)#channel-group 1 mode active
Creating a port-channel interface Port-channel 1
Apr 2 18:55:11.478: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to down
DSW1-Cat3560(config-if)#int fa0/2
DSW1-Cat3560(config-if)#channel-protocol lacp
DSW1-Cat3560(config-if)#
Apr 2 18:55:19.472: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up
DSW1-Cat3560(config-if)#channel-group 1 mode active
DSW1-Cat3560(config-if)#^Z
DSW1-Cat3560#sh etherchan
Apr 2 18:55:31.887: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/2, changed state to down
Apr 2 18:55:32.072: %SYS-5-CONFIG_I: Configured from console by tshoot on console
DSW1-Cat3560#sh etherchannel summary 
Flags: D - down P - bundled in port-channel
 I - stand-alone s - suspended
 H - Hot-standby (LACP only)
 R - Layer3 S - Layer2
 U - in use f - failed to allocate aggregator
M - not in use, minimum links not met
 u - unsuitable for bundling
 w - waiting to be aggregated
 d - default port

Number of channel-groups in use: 1
Number of aggregators: 1
Group Port-channel Protocol Ports
------+-------------+-----------+-----------------------------------------------
1 Po1(SD) LACP Fa0/1(I) Fa0/2(I)

 

I = Individual, azaz nem vesz részt a port-channelben. Azért, mert ASW1-et még nem konfiguráltam fel.

ASW1-Cat3550#
ASW1-Cat3550#
ASW1-Cat3550#
ASW1-Cat3550#conf t
Enter configuration commands, one per line. End with CNTL/Z.
ASW1-Cat3550(config)#int fa0/1
ASW1-Cat3550(config-if)#channel-protocol lacp
AASW1-Cat3550(config-if)#channel-group 1 mode passive
Creating a port-channel interface Port-channel 1
ASW1-Cat3550(config-if)#
07:58:51: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to down
ASW1-Cat3550(config-if)#int fa0/2
ASW1-Cat3550(config-if)#channel-protocol lacp
ASW1-Cat3550(config-if)#
07:59:03: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up
ASW1-Cat3550(config-if)#
07:59:04: %LINK-3-UPDOWN: Interface Port-channel1, changed state to up
07:59:05: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel1, changed state to up
ASW1-Cat3550(config-if)##channel-group 1 mode passive
ASW1-Cat3550(config-if)#
ASW1-Cat3550(config-if)#^Z
ASW1-Cat3550#
ASW1-Cat3550#
07:59:09: %SYS-5-CONFIG_I: Configured from console by tshoot on console
ASW1-Cat3550#
ASW1-Cat3550#
ASW1-Cat3550#sh etherc
ASW1-Cat3550#sh etherchannel suim  mm

Number of channel-groups in use: 1
Number of aggregators: 1
Group Port-channel Protocol Ports
------+-------------+-----------+-----------------------------------------------
1 Po1(SU) LACP Fa0/1(P) Fa0/2(P)

P = részt vesz a port-channelben.

 

Csináljunk egy Layer3-as Etherchannelt, Fa0/47-tel és Fa0/48-cal, 10.0.0.0 /30-as IP tartománnyal:

 

DSW1-Cat3560#
DSW1-Cat3560#
DSW1-Cat3560#
DSW1-Cat3560#
DSW1-Cat3560#conf t
Enter configuration commands, one per line. End with CNTL/Z.
DSW1-Cat3560(config)#int fa0/48
DSW1-Cat3560(config-if)#no switchport  
DSW1-Cat3560(config-if)#channe
Apr 2 18:58:51.201: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/47, changed state to down
DSW1-Cat3560(config-if)#channel-protocol pagp
DSW1-Cat3560(config-if)#channel-group 10 mode on
Creating a port-channel interface Port-channel 10
Apr 2 18:59:06.980: %LINK-3-UPDOWN: Interface Port-channel10, changed state to up
Apr 2 18:59:07.986: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel10, changed state to up
DSW1-Cat3560(config-if)#exit
DSW1-Cat3560(config)#int po10
DSW1-Cat3560(config-if)#ip add 10.0.0.1 255.255.255.252
DSW1-Cat3560(config-if)#^Z
DSW1-Cat3560#conf
Apr 2 18:59:19.135: %SYS-5-CONFIG_I: Configured from console by tshoot on console
DSW1-Cat3560#conf t
Enter configuration commands, one per line. End with CNTL/Z.
DSW1-Cat3560(config)#int fa0/48
DSW1-Cat3560(config-if)#no sw
DSW1-Cat3560(config-if)#c
Apr 2 18:59:25.669: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/48, changed state to down
DSW1-Cat3560(config-if)#channel.p  
Apr 2 18:59:27.683: %LINK-3-UPDOWN: Interface FastEthernet0/48, changed state to up
Apr 2 18:59:28.689: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/48, changed state to up
DSW1-Cat3560(config-if)#channel-proto
DSW1-Cat3560(config-if)#channel-protocol pagp
DSW1-Cat3560(config-if)#channel-group 10 mode on
DSW1-Cat3560(config-if)#^Z
DSW1-Cat3560#
DSW1-Cat3560#
DSW1-Cat3560#
DSW1-Cat3560#
DSW1-Cat3560#
DSW1-Cat3560#s
Apr 2 18:59:41.272: %SYS-5-CONFIG_I: Configured from console by tshoot on console
DSW1-Cat3560#sh ether
DSW1-Cat3560#sh etherchannel summ
DSW1-Cat3560#sh etherchannel summary 
Flags: D - down P - bundled in port-channel
 I - stand-alone s - suspended
 H - Hot-standby (LACP only)
 R - Layer3 S - Layer2
 U - in use f - failed to allocate aggregator
M - not in use, minimum links not met
 u - unsuitable for bundling
 w - waiting to be aggregated
 d - default port

Number of channel-groups in use: 2
Number of aggregators: 2
Group Port-channel Protocol Ports
------+-------------+-----------+-----------------------------------------------
1 Po1(SU) LACP Fa0/1(P) Fa0/2(P) 
10 Po10(RU) - Fa0/47(P) Fa0/48(P)

 

Tehát:

  • no switchport: ezzel a paranccsal Layer3 interface-re konfigoljuk a portot
  • a többi ugyanúgy megy, mint L2-es EtherChannel-nél, kivéve, hogy a Po10-nek IP-t adunk.

 

Működik a ping is:

DSW1-Cat3560#ping 10.0.0.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/8 ms
DSW1-Cat3560#
DSW1-Cat3560#
DSW1-Cat3560#

A topológia a labor végére a következőképpen változott:

 

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.